Saturday, July 19, 2008

Technology level Upgrade Steps for AIX

Step 1) Download the appropriate TL from the below link.
http://www-912.ibm.com/eserver/support/fixes/

Step 2) Oslevel –r to check the current version of the AIX.

Output will be like below.
bash-3.00# oslevel -r
5200-10

Step 3) lppchk –v to verify that all file sets have all required requisites and are completely installed.

Smit commit ( cOMMIT All the softwares which are installed on the machine.


Step4) smitty update_all To install the ML.

Step 5) oslevel –rl 5200-15 ? to determine which file sets are missing

Output will be like below.


bash-3.00# oslevel -rl 5100-09
Fileset Actual Level Recommended ML
-----------------------------------------------------------------------------
devices.scsi.disk.diag.com 5.1.0.50 5.1.0.55


The output from this command told me I was missing the following fileset

devices.scsi.disk.diag.com

Step 6) Determine the APAR for your missing filesets

This fileset is a part which APAR? The APAR number was determined by using


instfix -icq | grep devices.scsi.disk.diag.com


Output will be below.

-bash-3.00# instfix -icq | grep devices.scsi.disk.diag.com
5.1.0.0_AIX_ML:devices.scsi.disk.diag.com:5.1.0.0:5.1.0.50:+:AIX 5.1.0.0 Release
5100-01_AIX_ML:devices.scsi.disk.diag.com:5.1.0.10:5.1.0.50:+:AIX 5100-01 Update
IY22854:devices.scsi.disk.diag.com:5.1.0.15:5.1.0.50:+:Required updates for eServer pSeries p690
5100-02_AIX_ML:devices.scsi.disk.diag.com:5.1.0.25:5.1.0.50:+:AIX 5100-02 Update
5100-03_AIX_ML:devices.scsi.disk.diag.com:5.1.0.35:5.1.0.50:+:AIX 5100-03 Update
5100-04_AIX_ML:devices.scsi.disk.diag.com:5.1.0.50:5.1.0.50:=:AIX 5100-04 Update
IY37867:devices.scsi.disk.diag.com:5.1.0.50:5.1.0.50:=:Add Diagnostic Support for a Slimline IDE DVDROM
IY33586:devices.scsi.disk.diag.com:5.1.0.35:5.1.0.50:+:The DVDROM download microcode does not display usage error.
IY33489:devices.scsi.disk.diag.com:5.1.0.35:5.1.0.50:+:Microcode Download Support for DVDROM Drives
IY32871:devices.scsi.disk.diag.com:5.1.0.35:5.1.0.50:+:Need to export extract_vpd_kw
IY31162:devices.scsi.disk.diag.com:5.1.0.35:5.1.0.50:+:lscfg -vp causes coredump
IY29658:devices.scsi.disk.diag.com:5.1.0.35:5.1.0.50:+:lscfg -vp core dump
IY27849:devices.scsi.disk.diag.com:5.1.0.25:5.1.0.50:+:Serial disk format & certify fail
IY23123:devices.scsi.disk.diag.com:5.1.0.15:5.1.0.50:+:Periodic Diagnostics: Default should be to only test proces
IY21615:devices.scsi.disk.diag.com:5.1.0.15:5.1.0.50:+:No service action displayed for certify failures
IY21326:devices.scsi.disk.diag.com:5.1.0.15:5.1.0.50:+:Gramatical error in message file
IY18557:devices.scsi.disk.diag.com:5.1.0.10:5.1.0.50:+:Drive unconfigured errors and cosmetic fixes
5100-05_AIX_ML:devices.scsi.disk.diag.com:5.1.0.51:5.1.0.50:-:AIX 5100-05 Update
5100-06_AIX_ML:devices.scsi.disk.diag.com:5.1.0.54:5.1.0.50:-:AIX 5100-06 Update
5100-07_AIX_ML:devices.scsi.disk.diag.com:5.1.0.55:5.1.0.50:-:AIX 5100-07 Update
5100-08_AIX_ML:devices.scsi.disk.diag.com:5.1.0.55:5.1.0.50:-:AIX 5100-08 Update
5100-09_AIX_ML:devices.scsi.disk.diag.com:5.1.0.55:5.1.0.50:-:AIX 5100-09 Update
IY47320:devices.scsi.disk.diag.com:5.1.0.51:5.1.0.50:-:New function
IY48980:devices.scsi.disk.diag.com:5.1.0.52:5.1.0.50:-:Cannot certify a disk of type sispdisk using diagnostics
IY54381:devices.scsi.disk.diag.com:5.1.0.54:5.1.0.50:-:new function
IY46285:devices.scsi.disk.diag.com:5.1.0.51:5.1.0.50:-:Support for new diagnostic function.
IY47416:devices.scsi.disk.diag.com:5.1.0.51:5.1.0.50:-:new function
-bash-3.00#


The output is broken down into six colon separated tokens. They breakdown as follows:

keyword name:fileset name:required level:installed level:status:abstract



Step 7) Use instfix -i |grep ML to check in which ML the filesets are lagging as below.

-bash-3.00# instfix -i |grep ML
All filesets for 5.1.0.0_AIX_ML were found.
All filesets for 5100-01_AIX_ML were found.
All filesets for 5100-02_AIX_ML were found.
All filesets for 5100-03_AIX_ML were found.
All filesets for 5100-04_AIX_ML were found.
Not all filesets for 5100-05_AIX_ML were found.
Not all filesets for 5100-06_AIX_ML were found.
Not all filesets for 5100-07_AIX_ML were found.
Not all filesets for 5100-08_AIX_ML were found.
Not all filesets for 5100-09_AIX_ML were found.
-bash-3.00# instfix -ciqk 5100-05_AIX_ML | grep :-:


Step 8)use instfix to determine the missing filesets as shown in the following example

-bash-3.00# instfix -ciqk 5100-05_AIX_ML | grep :-:
5100-05_AIX_ML:devices.scsi.disk.diag.com:5.1.0.51:5.1.0.50:-:AIX 5100-05 Update
-bash-3.00#
-bash-3.00# instfix -ciqk 5100-05_AIX_ML | grep :-:
5100-05_AIX_ML:devices.scsi.disk.diag.com:5.1.0.51:5.1.0.50:-:AIX 5100-05 Update
-bash-3.00#
-bash-3.00# instfix -ciqk 5100-06_AIX_ML | grep :-:
5100-06_AIX_ML:devices.scsi.disk.diag.com:5.1.0.54:5.1.0.50:-:AIX 5100-06 Update
-bash-3.00#
-bash-3.00# instfix -ciqk 5100-07_AIX_ML | grep :-:
5100-07_AIX_ML:devices.scsi.disk.diag.com:5.1.0.55:5.1.0.50:-:AIX 5100-07 Update
-bash-3.00# instfix -ciqk 5100-08_AIX_ML | grep :-:
5100-08_AIX_ML:devices.scsi.disk.diag.com:5.1.0.55:5.1.0.50:-:AIX 5100-08 Update
-bash-3.00# instfix -ciqk 5100-09_AIX_ML | grep :-:
5100-09_AIX_ML:devices.scsi.disk.diag.com:5.1.0.55:5.1.0.50:-:AIX 5100-09 Update



The six fields above (: delimited) indicate:
The OS/ML identifier, the fileset name, the REQUIRED fileset level to attain the ML, the INSTALLED fileset level,
the fileset status and the source abstract


Step 9) bosboot -ad hdiskn ( where n is the harddisk where rootvg resids)

step 10) reboot the machine.

No comments: